Tech. Forum 개발자들을 위한 정보 공유의 장입니다
닫기

Tech.Forum

Android에서 설치된 TMap이 하위버전일 경우 TMapTapi 하위호환 문의

#1

안녕하세요. TMapTapi 사용 중 하위 호환에 대하여 문의 드립니다.

TMapTapi 중 invokeNavigation API사용에 대해 문의 드립니다.
Android에서 설치된 TMap이 하위버전일 경우 invokeNavigation API를 호출 하면 별다른 exception이 발생하지 않고
console에 하위버전 안내 메시지만 출력되고 있습니다.

설치된 TMap이 하위버전일 때는 invokeNavitaion API가 아닌 다른 API를 호출 하는 방식으로 우회할 수 있는 방법이 있을까요?

고맙습니다.

0 Likes

#2

안녕하세요.
T map API 운영담당자 입니다.

현재 TMap API에서는 별도로 하위버전을 체크하는 API는 제공해 드리고 있지않아 모바일에서 별도로 버전 체크 로직을 추가해주시면 진행가능합니다.

안드로이드 버전 체크에 관련하면 아래를 참고하시면 도움이 되실 것 겁니다.

---------------------------------- https://cnwlcjf.tistory.com/7 ----------------------------------

감사합니다.

0 Likes